Bug 8080 - Saving when adding/editing subclusters in tlwebadm does not return to base page
Summary: Saving when adding/editing subclusters in tlwebadm does not return to base page
Status: CLOSED FIXED
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Web Administration (show other bugs)
Version: trunk
Hardware: Other Other
: P2 Normal
Target Milestone: 4.15.0
Assignee: Frida
URL:
Keywords: prosaic, tobfa_tester
Depends on:
Blocks:
 
Reported: 2023-01-31 16:58 CET by Tobias
Modified: 2023-07-05 09:25 CEST (History)
1 user (show)

See Also:
Acceptance Criteria:
The user should be returned to the base page after * Pressing Save when adding a new subcluster * Pressing Save when editing an existing subcluster The user should NOT be returned to the base page after * Triggering errors when pressing Save while adding a new subcluster * Triggering errors when pressing Save while editing an existing subcluster


Attachments

Description Tobias cendio 2023-01-31 16:58:51 CET
On the VSM/Subclusters page, unlike other pages, pressing the Save button when adding or editing a list item does not return the user to the base page. While the saving mechanism seems to be working as intended, it proceeds to edit mode of the item the user just added, giving the impression that nothing was actually added.
Comment 2 Frida cendio 2023-02-06 13:23:54 CET
Should be fixed now. If there is an error when saving the user is not returned to the base page.

> The user should be returned to the base page after
> * Pressing Save when adding a new subcluster
yes

> * Pressing Save when editing an existing subcluster
yes


Also made sure that the changes are saved correctly.
Comment 3 Tobias cendio 2023-02-13 15:03:09 CET
Tested with server build #3049 on Fedora37 in Firefox 109.

Acceptance criteria:
The user should be returned to the base page after
[✓] Pressing Save when adding a new subcluster
[✓] Pressing Save when editing an existing subcluster

While the acceptance criteria are met with no errors encountered, there are discrepancies in the behaviour of the page when errors are encountered while creating a new subcluster and editing an existing subcluster.

In the former case, one is returned to the base page with errors displayed at the top. In the latter case, one remains on the popup page with errors displayed behind the popup.

It is not important that the error dialogues appear at incorrect places, since that fix is implemented in a later build. What's expected from this build #3049 is that when creating a new subcluster and encountering errors, the error dialogues should appear behind the popup while one remains on the popup page.

Triggering errors in the latest build, #3063, while in the process of making a new subcluster, one is returned to the base page with no errors displayed at all. Conversely, triggering errors while editing an existing subcluster retains the user on the popup page with errors displayed at the top, as is intended.

To properly cover the expected behaviour on the subcluster page, it seems we need to update this bug with additional acceptance criteria including the error cases.
Comment 4 Frida cendio 2023-02-21 08:08:50 CET
Tested build 3078 and everything seems to work fine. The issue that the popup closes when getting an error on save was solved indirectly by commit r39752 for bug 8075. 

> The user should be returned to the base page after
> * Pressing Save when adding a new subcluster
Yes

> * Pressing Save when editing an existing subcluster
Yes

> The user should NOT be returned to the base page after
> * Triggering errors when pressing Save while adding a new subcluster
It isn't

> * Triggering errors when pressing Save while editing an existing subcluster
It isn't
Comment 5 Tobias cendio 2023-03-02 09:22:46 CET
Tested on server build #3075 (pre-fix, preceding fixing commit r39752 mentioned in comment 4) and #3099 (post-fix, latest build) on Fedora37 in Firefox 109.0.1.

#3075 (pre-fix):
* The user should be returned to the base page after
  [✓] Pressing Save when adding a new subcluster
  [✓] Pressing Save when editing an existing subcluster
* The user should NOT be returned to the base page after
  [x] Triggering errors when pressing Save while adding a new subcluster
  [✓] Triggering errors when pressing Save while editing an existing subcluster

#3099 (post-fix):
* The user should be returned to the base page after
  [✓] Pressing Save when adding a new subcluster
  [✓] Pressing Save when editing an existing subcluster
* The user should NOT be returned to the base page after
  [✓] Triggering errors when pressing Save while adding a new subcluster
  [✓] Triggering errors when pressing Save while editing an existing subcluster

Conclusion:
In the post-fix build, acceptance criteria are met: pressing save in the popup -- with or without errors -- is working as intended. Closing.

Note You need to log in before you can comment on or make changes to this bug.