Bug 7968 - ThinLinc doesn't respect dark mode settings
Summary: ThinLinc doesn't respect dark mode settings
Status: NEW
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Other (show other bugs)
Version: trunk
Hardware: PC Unknown
: P2 Normal
Target Milestone: LowPrio
Assignee: Bugzilla mail exporter
URL:
Keywords:
Depends on: 7938
Blocks:
  Show dependency treegraph
 
Reported: 2022-07-15 08:14 CEST by Pierre Ossman
Modified: 2024-01-24 12:26 CET (History)
1 user (show)

See Also:
Acceptance Criteria:


Attachments
Current webaccess with Dark Reader enabled (35.18 KB, image/png)
2023-01-17 14:52 CET, Frida
Details
tl-4.14.0 webaccess with Dark Reader enabled (34.01 KB, image/png)
2023-01-17 14:53 CET, Frida
Details

Description Pierre Ossman cendio 2022-07-15 08:14:19 CEST
It has recently become rather popular with a "dark" mode for user interfaces. It started as a power saving feature on OLED devices, but has now got popular for purely aesthetic reasons.

ThinLinc currently doesn't respect dark mode settings in any part of the product, which can make it look very out of place.

Basically, every user interface should ideally respect dark mode:

 * Client
 * Client installer
 * Server installer
 * Profile chooser and xstartup feedback
 * Web Access
 * Web Administration
 * TAG
Comment 1 Pierre Ossman cendio 2022-07-15 08:15:39 CEST
We might have issues for the GTK based stuff as GTK 4 was where full dark mode support was added, and we're stuck on GTK 3 for the foreseeable future.
Comment 2 Frida cendio 2023-01-17 14:52:18 CET
Created attachment 1103 [details]
Current webaccess with Dark Reader enabled
Comment 3 Frida cendio 2023-01-17 14:53:04 CET
Created attachment 1104 [details]
tl-4.14.0 webaccess with Dark Reader enabled
Comment 4 Frida cendio 2023-01-17 14:54:55 CET
While waiting on this to be fixed, we might want to make sure our UIs looks good with commonly used automatic dark mode solutions. 

I was testing Dark Reader extension in Chrome and tlwebadm and tlwebaccess does not look good with this extension. For some reason the background is not inverted but the text is. Making it light gray text on white background, which is hard to read. See attachment 1103 [details]. 

With tl-4.14.0 it looked better. See attachment 1104 [details].
Comment 5 Pierre Ossman cendio 2024-01-24 12:26:09 CET
Casually requested on this YouTube video:

>  Wonder if they added like dark mode as I know before it was as a bright light in my face :P 

https://www.youtube.com/watch?v=2RHhabUiRjk&lc=UgxV8JGGB5Hm0ho7cVd4AaABAg

Note You need to log in before you can comment on or make changes to this bug.