Bug 7538 - Specifying a server via Applescript tries to open the server name as a config file
Summary: Specifying a server via Applescript tries to open the server name as a config...
Status: NEW
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Client (show other bugs)
Version: 4.12.0
Hardware: Mac macOS
: P2 Minor
Target Milestone: LowPrio
Assignee: Bugzilla mail exporter
Depends on:
Reported: 2020-07-17 19:52 CEST by Ted Johansson
Modified: 2020-08-27 13:01 CEST (History)
0 users

See Also:
Acceptance Criteria:


Description Ted Johansson 2020-07-17 19:52:02 CEST
Upgraded client software on latest MacOS. No problems with previous versions.
The client seems to be working OK otherwise.
Comment 1 Ted Johansson 2020-07-17 20:03:15 CEST
I use ThinLinc to connect to almost ten different computers... ThinLinc is really lacking a Connection Editor!
However, I solved it using MacOS Script Editor to issue different session using a simple icon. 
Typically "do shell script "/Applications/Kommunikation/ThinLinc\\ Client.app/Contents/MacOS/tlclient djursholm.my.to:5876 --u ted -p Sommar19! &> /dev/null 2>&1&" "
With previous version, it worked fined. But not with 4.12.0. 
The general settings are saved in ~/.thinlinc/tlclient.conf.

Here is as intereesting part of the tlclient.log:
2020-07-17T20:00:52: Log file created
2020-07-17T20:00:52: ThinLinc client release 4.12.0 build 6517
2020-07-17T20:00:52: Error: Couldn't open config to file 'djursholm.my.to:5876' for writing
2020-07-17T20:00:54: Last line was repeated 1 time(s).
Comment 2 Pierre Ossman cendio 2020-08-26 11:23:27 CEST
I can reproduce this here. There is something odd going on with the script engine as running the same command in a shell works just fine. We'll need to dig a bit further.
Comment 3 Pierre Ossman cendio 2020-08-27 13:01:20 CEST
After some testing this is some bug/misfeature of Applescript. It takes a wild guess that one of the arguments is a filename and tells ThinLinc to open it. 

Unfortunately I'm not finding any way to work around this behaviour. We've filed a bug report with Apple but unfortunately Applescript is not part of their developer support. So we've opened a thread on their developer forum instead:


The reason older versions worked is because ThinLinc 4.12.0 got some compatibility fixes in this area. Removing those fixes makes the scenario here work, but will likely break other cases.

So right now there unfortunately isn't anything we can do. Hopefully this gets fixed in Applescript, or someone repsonds on the developer forum with a way to work around this behaviour.

What you can try is using a script as an intermediary and not call the ThinLinc client directly. Perhaps there is a way to fool Applescript.

Note You need to log in before you can comment on or make changes to this bug.