Bug 7411 - The context menu hint is displayed even if no hotkey is chosen
Summary: The context menu hint is displayed even if no hotkey is chosen
Status: CLOSED FIXED
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: VNC (show other bugs)
Target Milestone: 4.11.0
Assignee: Samuel Mannehed
URL:
Keywords: ossman_tester, relnotes
Depends on:
Blocks:
 
Reported: 2019-10-25 10:08 CEST by Samuel Mannehed
Modified: 2019-10-28 10:27 CET (History)
0 users

See Also:
Acceptance Criteria:


Attachments

Description Samuel Mannehed cendio 2019-10-25 10:08:07 CEST
Steps to reproduce:

1. Start the native ThinLinc client
2. Open the Options and change the "Popup menu key" to 'None'
3. Login to a server
4. Observe that the hint at the top of the screen says:

    "Press  to open the context menu"

We shouldn't display this hint if there isn't a key bound to it.
Comment 2 Samuel Mannehed cendio 2019-10-25 10:49:12 CEST
Since this was such a small fix I bypassed the vendordrop routine and committed directly to ThinLinc. Upstream PR here:

https://github.com/TigerVNC/tigervnc/pull/894

Built and tested on Fedora 30.
Comment 3 Pierre Ossman cendio 2019-10-28 10:27:19 CET
Looks good. Got a confusing hint in the previous version with "None" configured, but nothing at all now. Also verified that that a properly configured menu key still gets the hint.

Note You need to log in before you can comment on or make changes to this bug.