Bug 7377 - Can't use pre-selected public key with Windows 64-bit client
Summary: Can't use pre-selected public key with Windows 64-bit client
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Client (show other bugs)
Version: trunk
Hardware: PC Windows
: P2 Normal
Target Milestone: 4.11.0
Assignee: Alex Tanskanen
Keywords: nikle_tester, relnotes
Depends on:
Reported: 2019-09-04 11:04 CEST by Samuel Mannehed
Modified: 2019-10-03 12:58 CEST (History)
1 user (show)

See Also:
Acceptance Criteria:


Description Samuel Mannehed cendio 2019-09-04 11:04:53 CEST
Using public key authentication on the Windows ThinLinc client you will get an error saying:

"The selected key can't be read or belongs to someone else. Please try again with a different key file."

This happens when the client is started with a public key file already chosen. If you selected a key file the last time you ran the client it will be saved for the next time you start the client.
Comment 3 Alex Tanskanen cendio 2019-10-02 11:31:32 CEST
Tested this and it works for Windows 10.
Comment 4 Samuel Mannehed cendio 2019-10-03 12:58:12 CEST
Verified that the problem existed with 4.10.1, but was actually only able to reproduce it when running the 64-bit client on Windows. We tried multiple times with the x86 client and it never showed the problem.

The fix looks good, however. Verified that a pre-selected file always worked fine using build 6255.

Note You need to log in before you can comment on or make changes to this bug.