Bug 7162 - cannot build cenbuild packages on Fedora 27+
Summary: cannot build cenbuild packages on Fedora 27+
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Build system (show other bugs)
Version: 1.3.1
Hardware: PC Unknown
: P2 Normal
Target Milestone: 4.10.0
Assignee: Pierre Ossman
Keywords: prosaic, samuel_tester
Depends on:
Blocks: 7179
  Show dependency treegraph
Reported: 2018-04-24 16:03 CEST by Pierre Ossman
Modified: 2018-05-23 10:24 CEST (History)
2 users (show)

See Also:
Acceptance Criteria:


Description Pierre Ossman cendio 2018-04-24 16:03:32 CEST
The build craps out with lots of errors about unpackaged files. All of these files are generated by the debuginfo magic though.

It seems they did some changes to this system in Fedora 27:

Comment 1 Pierre Ossman cendio 2018-04-25 11:06:47 CEST
Something is very strange here. I should be able to disable this new feature doing:

%undefine _debugsource_packages

However that still fails with rpm complaining about the debug symbol file being unpackaged. It is however completely content with all the source code files. And both of these things are defined in the same debugfiles.list, so I have no idea why one works and the other doesn't.

I tried rebuilding a normal Fedora package with debugsource turned off and that worked fine, so it is possible to turn it off.
Comment 2 Pierre Ossman cendio 2018-05-16 13:46:27 CEST
Need to get this sorted now so we can upgrade things for the next release.
Comment 3 Pierre Ossman cendio 2018-05-17 11:08:34 CEST
The problem is that they've added a lot of checks for "noarch" inside the rpmbuild binary now. Previously those checks were all in the macros so we could override them.

Fortunately it is possible to disable this new feature completely, which makes our builds work again (until they add even more checks).

However, there is one more change as part of this. We're no longer build-id symlinks in /usr/lib/debug. That code has also gotten a noarch check that we cannot bypass. Because of this we probably need to turn off decorated debug file names so that tools such as gdb can still find the debug symbols.
Comment 5 Pierre Ossman cendio 2018-05-17 11:24:11 CEST
Builds are working fine now Fedora 27.
Comment 6 Samuel Mannehed cendio 2018-05-23 10:24:56 CEST
I successfully built 11 packages on my fedora 28 workstation. Looks good.

Note You need to log in before you can comment on or make changes to this bug.