Bug 6143 - handle_response API is poorly named
Summary: handle_response API is poorly named
Status: CLOSED FIXED
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: VSM Server (show other bugs)
Target Milestone: 4.16.0
Assignee: Pierre Ossman
URL:
Keywords: adaha_tester, prosaic
Depends on:
Blocks:
 
Reported: 2017-01-19 11:58 CET by Samuel Mannehed
Modified: 2023-11-07 13:51 CET (History)
3 users (show)

See Also:
Acceptance Criteria:
MUST: * handle_response() should be replaced with a better named method/system SHOULD: * All XML-RPC API functions/method/properties should have sensible naming


Attachments

Description Samuel Mannehed cendio 2017-01-19 11:58:43 CET
The method handle_response() is used to send the response back in a XMLRPC handler once all processing is done. This name is rather confusing as all other methods with "handle" in the name are callbacks. Perhaps "send_response()" would be better.
Comment 6 Pierre Ossman cendio 2023-10-27 10:22:04 CEST
This got fixed as part of bug 8224. handle_response() is now gone.
Comment 7 Adam Halim cendio 2023-11-02 11:18:31 CET
> MUST:
> 
>  * handle_response() should be replaced with a better named method/system ✓
> 
> SHOULD:
> 
>  * All XML-RPC API functions/method/properties should have sensible naming ✓

Looked through the commits, and with the conversion to asyncio, handle_response() has been removed/replaced with more sensible names.

Closing as all acceptance criteria are met.
Comment 8 Adam Halim cendio 2023-11-07 13:51:14 CET
(In reply to Adam Halim from comment #7)
> > MUST:
> > 
> >  * handle_response() should be replaced with a better named method/system ✓
> > 
> > SHOULD:
> > 
> >  * All XML-RPC API functions/method/properties should have sensible naming ✓
> 
> Looked through the commits, and with the conversion to asyncio,
> handle_response() has been removed/replaced with more sensible names.
> 
> Closing as all acceptance criteria are met.
Note that the code was only reviewed and not tested extensively as the focus of this bug was code structure/readability. All parts that were changed will be tested more thoroughly when bug 8224 closes.

Note You need to log in before you can comment on or make changes to this bug.