Bug 5681 - Support for eLux RP5
Summary: Support for eLux RP5
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Client platforms (show other bugs)
Version: trunk
Hardware: PC Unknown
: P2 Normal
Target Milestone: 4.6.0
Assignee: Pierre Ossman
Keywords: derfian_tester, relnotes
Depends on:
Reported: 2015-10-27 09:53 CET by Peter Åstrand
Modified: 2016-12-05 14:56 CET (History)
2 users (show)

See Also:
Acceptance Criteria:


Description Peter Åstrand cendio 2015-10-27 09:53:40 CET
eLux RP5 has a new package format. Packages are called UC_RP5-1.0 instead of UC_RP-1.0. A rename is not enough to load them into Elias.
Comment 1 Pierre Ossman cendio 2015-10-27 11:21:43 CET
We need to investigate how easy this is to upgrade, which terminals are supported, does it cost anything, are devices shipping with this version, etc?
Comment 3 Pierre Ossman cendio 2016-02-08 10:05:46 CET
Unicon have been contacted on issue 18535 to get new licences.
Comment 4 Pierre Ossman cendio 2016-02-08 10:33:40 CET
The following eLux terminals are no longer supported on RP 5:

Futro S100
Futro S450 (v2 still supported)
Futro S550 (v2 still supported)
Esprimo C700   
Esprimo C710   
Esprimo E700   
Esprimo E710   


eLux can also be used on terminals that originally run something different, and that list has also lost a few entries:


UD3 Nano       
UD5 Nano      

Itona F-Series F24 (BIOS V9F8-EL)      
Itona MD-Series (BIOS MdE1-EL)
Comment 5 Pierre Ossman cendio 2016-02-08 10:36:46 CET
There doesn't seem to be any extra cost involved for upgrading AFAICT, and Unicon's web page states:

> Subscription ensures that you can always use the latest software versions of
> eLux and Scout Enterprise as well as the latest application versions.

Comment 6 Pierre Ossman cendio 2016-02-08 10:46:21 CET
The machines we have are a Nexceed and a S900. So one of them is possible to upgrade. Or we could buy a new terminal.

For reference, eLux RL is supported until 2016-03-31 (i.e. it will be unsupported by the time the next ThinLinc is out). eLux RP 4 is supported until 2018-03-31 though.
Comment 7 Samuel Mannehed cendio 2016-02-18 10:16:29 CET
I have formatted our S900 and installed a fresh RP 4.11 on it. It is connected to Scout and working properly. The plan is that we upgrade this machine to RP 5.

I have also disconnected and put aside our Nexceed terminal. This machine will continue having RP 4, so that we can test it in the future if needed.
Comment 8 Pierre Ossman cendio 2016-02-18 16:20:41 CET
I tried out the mass upgrade method to update our S900 from RP4 to RP5. AFAICT it worked out fine. The graphics freaked out during the upgrade, but a few minutes later it was rebooted with an updated firmware.

I also did an updated ThinLinc package as part of this. Simply changing the container name was sufficient to get it to install. Will still need to do proper testing that everything works.
Comment 9 Pierre Ossman cendio 2016-02-18 17:13:08 CET
The client seems to work just fine on the new eLux. I've tested:

 - Multihead
 - Smart card auth
 - Smart card redir
 - Local drives
 - Sound
 - Local printer
Comment 11 Karl Mikaelsson cendio 2016-03-10 15:32:52 CET
Test results:

 ✓ Basic functionality
 ✓ Authentication methods
   ✓ Password
   ✓ Public key
   ✓ Smart card
   ✗ Kerberos (bug 5816)
 ✓ Local devices
   ✓ Sound
   ✓ Serial ports
   ✓ Drives
   ✓ Printing
   ✓ Smart card readers
 ✓ Multi monitor handling

Note You need to log in before you can comment on or make changes to this bug.