Bug 5484 - vncviewer F8 About dialog is displayed incorrectly
Summary: vncviewer F8 About dialog is displayed incorrectly
Status: CLOSED FIXED
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: VNC (show other bugs)
Target Milestone: 4.4.0
Assignee: Pierre Ossman
URL:
Keywords: prosaic, samuel_tester
Depends on:
Blocks:
 
Reported: 2015-04-02 14:39 CEST by Peter Åstrand
Modified: 2015-04-30 13:18 CEST (History)
1 user (show)

See Also:
Acceptance Criteria:


Attachments

Description Peter Åstrand cendio 2015-04-02 14:39:13 CEST
The About dialog, available from the F8 menu, is displayed incorrectly - using the wrong character encoding. This affects several languages, including Swedish. This problem was not present in 4.3.0. However, I'm unable to find which commit/bug is the cause of the problem. My guess is that it is this upstream commit:

https://github.com/TigerVNC/tigervnc/commit/63471c9de0892f32f237c97f081e14f66a2365ab

It got into our tree in r30154, which was unfortunately done without a bug reference. 

When testing this bug, make sure to check both the console printout, as well as the GUI dialog.
Comment 1 Pierre Ossman cendio 2015-04-07 15:07:36 CEST
r30214.

It is also important that this is tested where the console is not UTF-8.
Comment 2 Samuel Mannehed cendio 2015-04-30 13:18:25 CEST
Looks good.

* Have verified the about dialog on Linux with LANG=fr_FR tlclient
* Have verified the console output on Linux with LANG=fr_FR /opt/thinlinc/lib/tlclient/vncviewer
* Have tested with system locale set to sv_SE.ISO-8859-1 on Linux
* Have verified the about dialog on the windows client with Russian and French

Note You need to log in before you can comment on or make changes to this bug.