Bug 5413 - printer installation hangs if lpadmin needs a password
Summary: printer installation hangs if lpadmin needs a password
Status: NEW
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Server Installer (show other bugs)
Version: pre-1.0
Hardware: PC Unknown
: P2 Normal
Target Milestone: MediumPrio
Assignee: Henrik Andersson
Depends on:
Reported: 2015-01-29 16:43 CET by Pierre Ossman
Modified: 2018-08-10 08:55 CEST (History)
1 user (show)

See Also:
Acceptance Criteria:


Description Pierre Ossman cendio 2015-01-29 16:43:22 CET
tl-setup failed to ever complete installing printers. After I finally killed lpadmin, I got this in tlsetup.log:

> 2015-01-29 16:40:26,920: Failed to run printer script '/opt/thinlinc/libexec/add_nearest_printer.sh'
> 2015-01-29 16:40:26,920: Output (stdout):
> 2015-01-29 16:40:26,920:     Using CUPS installed at prefix /
> 2015-01-29 16:40:26,920:     Using CUPS_SERVERBIN=/lib/cups
> 2015-01-29 16:40:26,920:     Adding CUPS backend nearest
> 2015-01-29 16:40:26,921:     Restarting CUPS to make it aware of changes...
> 2015-01-29 16:40:26,921:     Waiting for CUPS to start...
> 2015-01-29 16:40:26,921:     Password for root on printhost?  

I have yet to confirm if it is something odd on my system or if a default install of Fedora 21 behaves like this.

Still, we should never lock up like this. We should set things up so that the password prompt will fail and tl-setup can at least move on.
Comment 1 Karl Mikaelsson cendio 2015-06-04 13:15:26 CEST
I ran into the same issue when setting up ThinLinc on my Fedora 21. Cups asks for a password because it's trying to change the configuration on another server (printhost).

So I did some digging, and I found that when you specify just "-h localhost" to lpadmin, cups seems to respect the configuration in /etc/cups/client.conf and talk to the configured server.

If you however specify -h localhost:631, lpadmin will talk to the local cups server and not to the configured server in /etc/cups/client.conf.

I tried to look into the code to see why it's doing things this way, but I didn't find anything.

Note You need to log in before you can comment on or make changes to this bug.