Bug 4595 - xprop crashes
Summary: xprop crashes
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: VSM Agent (show other bugs)
Version: 4.0.0
Hardware: PC Unknown
: P2 Normal
Target Milestone: 4.1.0
Assignee: Pierre Ossman
Keywords: aaron_tester
Depends on:
Reported: 2013-04-15 17:23 CEST by Aaron Sowry
Modified: 2013-05-15 14:50 CEST (History)
0 users

See Also:
Acceptance Criteria:


Description Aaron Sowry cendio 2013-04-15 17:23:19 CEST
After logging into a session an error report pops up telling the user that xprop has crashed. Haven't tried to get any detailed explanation as to why, but the offending command is apparently:

/opt/thinlinc/libexec/xprop -root 32x \ $0\\n_NET_SUPPORTING_WM_CHECK
Comment 1 Pierre Ossman cendio 2013-04-16 14:14:33 CEST
The original report was for Ubuntu 13.04 Beta, but I also get this on Fedora 18.
Comment 2 Pierre Ossman cendio 2013-04-17 16:22:58 CEST
Our ancient xprop is horribly buggy. It abort():s whenever a property doesn't exist on a window. I'm amazed we haven't run in to this earlier.

The xprop in Fedora 18 works fine, so I think we'll just try an upgrade.
Comment 3 Pierre Ossman cendio 2013-04-18 10:45:03 CEST
xprop upgraded in r27105.
Comment 4 Aaron Sowry cendio 2013-05-15 14:50:52 CEST
Unable to reproduce using the new xprop on Ubuntu 13.04, so assuming that upgrading it has solved the problem. Closing.

Note You need to log in before you can comment on or make changes to this bug.