Bug 4242 - Windows client sometimes hangs when connecting to agent
Summary: Windows client sometimes hangs when connecting to agent
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: Client platforms (show other bugs)
Version: 3.2.0
Hardware: PC Unknown
: P2 Normal
Target Milestone: 4.1.0
Assignee: Pierre Ossman
Keywords: astrand_tester
Depends on:
Reported: 2012-03-28 12:36 CEST by Peter Åstrand
Modified: 2013-05-22 16:31 CEST (History)
0 users

See Also:
Acceptance Criteria:

tlclient.log (1.96 KB, text/plain)
2012-03-28 12:37 CEST, Peter Åstrand
tlclient.log when it works (4.82 KB, text/plain)
2012-03-28 12:48 CEST, Peter Åstrand
tlclient.log when using smart card login (2.41 KB, text/plain)
2012-05-15 14:47 CEST, Peter Åstrand

Description Peter Åstrand cendio 2012-03-28 12:36:41 CEST
Tried latest Windows client against our demo system, hanged when connecting to the agent. It seems like the thinlinc-login output was intermixed with the COMMAND_EXITSTATUS, see attached log.
Comment 1 Peter Åstrand cendio 2012-03-28 12:37:03 CEST
Created attachment 432 [details]
Comment 2 Peter Åstrand cendio 2012-03-28 12:48:07 CEST
Created attachment 433 [details]
tlclient.log when it works

Note that for the successful case, there's no output from thinlinc-login at all.
Comment 3 Pierre Ossman cendio 2012-04-03 10:21:58 CEST
First test to see how common this is. Test on several windows machines, and possibly against different servers.

Nightly build of the client needs to be used.
Comment 4 Aaron Sowry cendio 2012-04-23 11:18:20 CEST
Have attempted to reproduce this on Windows 7 and the XP machine in the lab - could not reproduce. Perhaps we should test again quickly on Peter's laptop before closing.
Comment 5 Peter Åstrand cendio 2012-04-26 13:25:57 CEST
More testing on my laptop, with build 3459. Seems to be rare. I tried 20 logins against different servers, sometimes reconnect, sometimes new session. In some cases, doing a file transfer against the same server. The result is:

No output from thinlinc-login: 12

Only HELLO: 1

Everything from thinlinc-login (ie unsupported service): 7

Intermixed, ie this bug: 0

IOW, we can probably pretend this bug does not exist right now.
Comment 6 Peter Åstrand cendio 2012-05-15 14:47:44 CEST
Created attachment 442 [details]
tlclient.log when using smart card login

Unfortunately, this bug happened again today, when using smart card auth against the demo system.
Comment 7 Pierre Ossman cendio 2013-01-10 13:41:07 CET
Will look at this whilst doing bug 3183.
Comment 8 Pierre Ossman cendio 2013-03-13 16:26:12 CET
This could in theory happen with OpenSSH as well. Seeing if things can be improved.
Comment 9 Pierre Ossman cendio 2013-03-13 16:34:54 CET
Fixed in r26792.

Tester could verify this with a malicious thinlinc-login that omits the last \n.
Comment 10 Peter Åstrand cendio 2013-05-22 16:31:22 CEST
Tried but failed to reproduce the problem with the 4.0 client; does not happen neither with my laptop against the demo system, neither with a malicious thinlinc-login. Anyway, the latest nightly build works fine as well, so assuming we do not see this elsewhere this test period, I'd say this problem is gone.

Note You need to log in before you can comment on or make changes to this bug.