Bug 3990 - Support emulation of 3 mouse buttons
Summary: Support emulation of 3 mouse buttons
Status: CLOSED FIXED
Alias: None
Product: ThinLinc
Classification: Unclassified
Component: VNC (show other bugs)
Target Milestone: 4.12.0
Assignee: Niko Lehto
URL:
Keywords: relnotes, samuel_tester, upstream
Depends on:
Blocks:
 
Reported: 2011-09-13 11:17 CEST by Peter Åstrand
Modified: 2020-06-25 10:42 CEST (History)
3 users (show)

See Also:
Acceptance Criteria:


Attachments

Description Peter Åstrand cendio 2011-09-13 11:17:16 CEST
The old Windows vncviewer had an option for emulating 3 mouse buttons. The new one does not. This can be a problem with devices which lacks 3 buttons. This includes many laptops.
Comment 2 Pierre Ossman cendio 2018-11-26 12:53:35 CET
Upstream issue:

https://github.com/TigerVNC/tigervnc/issues/540
Comment 4 Niko Lehto cendio 2020-01-23 09:33:56 CET
Tested that checkbox setting persisted through restart for both Options menu in login and F8-menu. Verified with Xev that emulation works as intended.

Still needs updated screenshots for adminguide.
Comment 7 Samuel Mannehed cendio 2020-01-27 15:29:56 CET
Function works as intended, options look good both in tlclient and vncviewer, doc looks good. Relnotes look good. Tested on Fedora 31 and Windows 10.
Comment 9 Niko Lehto cendio 2020-06-25 10:13:23 CEST
Some of the translations for the option "Emulate middle mouse button" in client options is too long, or on the verge of being too long. We should shuffle the UI around to give this option more room.

This was an issue for translations in:
 - FR
 - RU
 - IT
Comment 11 Pierre Ossman cendio 2020-06-25 10:40:40 CEST
Moved it to a separate line so we don't run out of space.
Comment 12 Niko Lehto cendio 2020-06-25 10:42:50 CEST
Tested this on the languages that had issues (fr, ru, it), and it looks good now!

Note You need to log in before you can comment on or make changes to this bug.